summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 904121e2e..f8303e137 100644
--- a/Makefile
+++ b/Makefile
@@ -440,6 +440,14 @@ external-deps:
@$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
SPIDER=--spider source
+ifeq ($(BR2_CONFIG_CACHE),y)
+$(BUILD_DIR)/tgt-config.cache: .config
+ rm -f $@
+ touch $@
+
+$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache
+endif
+
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig