summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
Diffstat (limited to 'boot')
-rw-r--r--boot/barebox/barebox.mk4
-rw-r--r--boot/u-boot/u-boot.mk4
2 files changed, 6 insertions, 2 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 7c2cbc123..85224cae0 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -53,9 +53,11 @@ barebox: $(BAREBOX_DIR)/.installed
ifeq ($(BR2_TARGET_BAREBOX),y)
TARGETS+=barebox
-# we NEED a board defconfig file
+# we NEED a board defconfig file unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(BAREBOX_BOARD_DEFCONFIG),)
$(error No Barebox defconfig file. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG setting)
endif
+endif
endif
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index f97674ada..971920751 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -193,9 +193,11 @@ u-boot-configured: $(U_BOOT_DIR)/.header_modified
ifeq ($(BR2_TARGET_UBOOT),y)
TARGETS+=u-boot
-# we NEED a board name
+# we NEED a board name unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(U_BOOT_BOARD_NAME),)
$(error NO U-Boot board name set. Check your BR2_TARGET_UBOOT_BOARDNAME setting)
endif
+endif
endif