summaryrefslogtreecommitdiff
path: root/fs/squashfs/squashfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/squashfs/squashfs.mk')
-rw-r--r--fs/squashfs/squashfs.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 6117de62a..aae22b6fd 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -19,7 +19,8 @@ endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))