summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/jffs2/Config.in4
-rw-r--r--fs/squashfs/squashfs.mk3
2 files changed, 5 insertions, 2 deletions
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index b787ec9d1..3f1656869 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -81,7 +81,9 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
the pagesize is not a power of 2
config BR2_JFFS2_TARGET_SREC
- bool "RootFS in SREC file formet"
+ bool "RootFS in SREC file format"
+ help
+ The binary data will be encoded in Motorola's S-record format
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 6117de62a..aae22b6fd 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -19,7 +19,8 @@ endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))