summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk3
-rw-r--r--fs/squashfs/squashfs.mk12
2 files changed, 13 insertions, 2 deletions
diff --git a/fs/common.mk b/fs/common.mk
index a3248c165..50dc97425 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -57,6 +57,9 @@ ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZMA),y)
$(LZMA) -9 -c $$@ > $$@.lzma
endif
+$(1)-root-show-depends:
+ @echo $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot host-makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
+
$(1)-root: $(BINARIES_DIR)/rootfs.$(1)
ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index f11ba2090..a9041828d 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -8,10 +8,18 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
+
+ifeq ($(BR2_ENDIAN),"BIG")
+ROOTFS_SQUASHF_ARGS=-be
+else
+ROOTFS_SQUASHFS_ARGS=-le
+endif
+
endif
define ROOTFS_SQUASHFS_CMD
- $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend
+ $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
+ $(ROOTFS_SQUASHFS_ARGS)
endef
-$(eval $(call ROOTFS_TARGET,squashfs)) \ No newline at end of file
+$(eval $(call ROOTFS_TARGET,squashfs))