summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/Config.in3
-rw-r--r--fs/squashfs/squashfs.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index 20aac085d..85416becb 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -31,6 +31,9 @@ choice
config BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
bool "gzip"
+config BR2_TARGET_ROOTFS_SQUASHFS4_LZMA
+ bool "lzma"
+
config BR2_TARGET_ROOTFS_SQUASHFS4_LZO
bool "lzo"
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 311a3ee1e..7efe979e8 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -10,8 +10,12 @@ ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
ROOTFS_SQUASHFS_ARGS += -comp lzo
else
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZMA),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzma
+else
ROOTFS_SQUASHFS_ARGS += -comp gzip
endif
+endif
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3