summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/Config.in19
-rw-r--r--fs/squashfs/squashfs.mk4
2 files changed, 23 insertions, 0 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index 6cc8fcae0..bcc93b925 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -2,3 +2,22 @@ config BR2_TARGET_ROOTFS_SQUASHFS
bool "squashfs root filesystem"
help
Build a squashfs root filesystem
+
+if BR2_TARGET_ROOTFS_SQUASHFS
+choice
+ prompt "SquashFS version"
+ default BR2_TARGET_ROOTFS_SQUASHFS4
+ help
+ Select the Squash filesystem version to use to generate the
+ root filesystem.
+
+config BR2_TARGET_ROOTFS_SQUASHFS4
+ bool "4.x"
+
+config BR2_TARGET_ROOTFS_SQUASHFS3
+ depends on BR2_DEPRECATED
+ bool "3.x"
+
+endchoice
+endif
+
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index d72388ebf..f11ba2090 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -4,7 +4,11 @@
#
#############################################################
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+else
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
+endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend