summaryrefslogtreecommitdiff
path: root/make/gcc-uclibc-2.95.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/gcc-uclibc-2.95.mk')
-rw-r--r--make/gcc-uclibc-2.95.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/make/gcc-uclibc-2.95.mk b/make/gcc-uclibc-2.95.mk
index a86809613..65a2e4e60 100644
--- a/make/gcc-uclibc-2.95.mk
+++ b/make/gcc-uclibc-2.95.mk
@@ -1,6 +1,7 @@
# Makefile for to build a gcc/uClibc toolchain
#
# Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
+# Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -75,7 +76,8 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
mkdir -p $(GCC_BUILD_DIR1)
-mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
- -(cd $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) ; ln -sf include sys-include)
+ # Important! Required for limits.h to be fixed.
+ ln -sf include $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
(cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
$(GCC_DIR)/configure \
--prefix=$(STAGING_DIR) \
@@ -85,7 +87,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
--enable-languages=c \
--disable-shared \
--includedir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include \
- --with-headers \
+ --with-headers=$(TOOL_BUILD_DIR)/uClibc_dev/usr/include \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \
@@ -166,7 +168,6 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/$(REAL_GNU_TAR
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--with-gxx-include-dir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include/c++ \
- --with-headers \
--disable-__cxa_atexit \
--enable-target-optspace \
--with-gnu-ld \