summaryrefslogtreecommitdiff
path: root/make/grep.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/grep.mk')
-rw-r--r--make/grep.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/grep.mk b/make/grep.mk
index 8fccf5be0..9ccfa4826 100644
--- a/make/grep.mk
+++ b/make/grep.mk
@@ -51,7 +51,8 @@ $(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
@if [ -L $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
+ @if [ ! -f $(GNUGREP_DIR)/$(GNUGREP_BINARY) -o $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) \
+ -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
set -x; \
rm -f $(TARGET_DIR)/bin/grep $(TARGET_DIR)/bin/egrep $(TARGET_DIR)/bin/fgrep; \
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \