summaryrefslogtreecommitdiff
path: root/make/stlport.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make/stlport.mk')
-rw-r--r--make/stlport.mk21
1 files changed, 3 insertions, 18 deletions
diff --git a/make/stlport.mk b/make/stlport.mk
index a778b9e79..af60d3055 100644
--- a/make/stlport.mk
+++ b/make/stlport.mk
@@ -3,22 +3,6 @@
# STLport standard C++ library
#
#############################################################
-# Copyright (C) 2002 by Erik Andersen <andersen@codepoet.org>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Library General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA
STLPORT_DIR=$(BUILD_DIR)/STLport-4.5.3
STLPORT_SITE=http://www.stlport.org/archive
@@ -30,11 +14,12 @@ $(DL_DIR)/$(STLPORT_SOURCE):
stlport-source: $(DL_DIR)/$(STLPORT_SOURCE) $(STLPORT_PATCH)
-$(STLPORT_DIR)/Makefile: $(DL_DIR)/$(STLPORT_SOURCE) $(STLPORT_PATCH)
+$(STLPORT_DIR)/.configured: $(DL_DIR)/$(STLPORT_SOURCE) $(STLPORT_PATCH)
zcat $(DL_DIR)/$(STLPORT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
cat $(STLPORT_PATCH) | patch -d $(STLPORT_DIR) -p1
+ touch -c $(STLPORT_DIR)/.configured
-$(STLPORT_DIR)/lib/libstdc++.so.4.5: $(STLPORT_DIR)/Makefile
+$(STLPORT_DIR)/lib/libstdc++.so.4.5: $(STLPORT_DIR)/.configured
$(MAKE) ARCH=$(ARCH) PREFIX=$(STAGING_DIR) -C $(STLPORT_DIR)
$(STAGING_DIR)/lib/libstdc++.so.4.5: $(STLPORT_DIR)/lib/libstdc++.so.4.5