summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 61fcfcfa2..917600ca0 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -57,9 +57,16 @@ ifndef $(2)_LIBTOOL_PATCH
endif
endif
+ifndef $(2)_MAKE
+ ifdef $(3)_MAKE
+ $(2)_MAKE = $($(3)_MAKE)
+ else
+ $(2)_MAKE ?= $(MAKE)
+ endif
+endif
+
$(2)_CONF_ENV ?=
$(2)_CONF_OPT ?=
-$(2)_MAKE ?= $(MAKE)
$(2)_MAKE_ENV ?=
$(2)_MAKE_OPT ?=
$(2)_AUTORECONF ?= NO