summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 09f44b46f..f0f189f90 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -140,12 +140,13 @@ define LIBTOOL_PATCH_HOOK
$(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES" -a \
"$$($$(PKG)_AUTORECONF)" != "YES"; then \
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
- toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool.patch; \
done \
fi
endef
-ifeq ($($(2)_LIBTOOL_PATCH),YES)
+# default values are not evaluated yet, so don't rely on this defaulting to YES
+ifneq ($($(2)_LIBTOOL_PATCH),NO)
$(2)_POST_PATCH_HOOKS += LIBTOOL_PATCH_HOOK
endif