summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index c4c4b1ceb..d36c884f0 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -188,7 +188,8 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(BUILD_DIR)/%/.stamp_libtool_patch:
$(call MESSAGE,"Patching libtool")
# if the package uses libtool, patch it for cross-compiling in buildroot
- $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES"; then \
+ $(Q)if test "$($(PKG)_LIBTOOL_PATCH)" = "YES" -a \
+ "$($(PKG)_AUTORECONF)" != "YES"; then \
for i in `find $(@D) -name ltmain.sh`; do \
toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
done \