summaryrefslogtreecommitdiff
path: root/package/Makefile.cmake.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.cmake.in')
-rw-r--r--package/Makefile.cmake.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.cmake.in b/package/Makefile.cmake.in
index 38e459b80..4a4ad6e2d 100644
--- a/package/Makefile.cmake.in
+++ b/package/Makefile.cmake.in
@@ -96,6 +96,10 @@ endef
endif
endif
+# This must be repeated from GENTARGETS_INNER, otherwise we only get
+# host-cmake in _DEPENDENCIES because of the following line
+$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+
$(2)_DEPENDENCIES += host-cmake
#