summaryrefslogtreecommitdiff
path: root/package/Makefile.cmake.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.cmake.in')
-rw-r--r--package/Makefile.cmake.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/Makefile.cmake.in b/package/Makefile.cmake.in
index 1263eb993..38e459b80 100644
--- a/package/Makefile.cmake.in
+++ b/package/Makefile.cmake.in
@@ -183,15 +183,13 @@ endef
################################################################################
# CMAKETARGETS -- the target generator macro for CMake packages
#
-# Argument 1 is the package directory prefix [mandatory]
-# Argument 2 is the lowercase package name [mandatory]
-# Argument 3 is "target" or "host" [optional, default: "target"]
+# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
define CMAKETARGETS
-ifeq ($(3),host)
-$(call CMAKETARGETS_INNER,$(3)-$(2),$(call UPPERCASE,$(3)-$(2)),$(call UPPERCASE,$(2)),$(1),host)
+ifeq ($(1),host)
+$(call CMAKETARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
else
-$(call CMAKETARGETS_INNER,$(2),$(call UPPERCASE,$(2)),$(call UPPERCASE,$(2)),$(1),target)
+$(call CMAKETARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
endif
endef