summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 36f2f2419..bb2aafa4c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -93,11 +93,20 @@ LIBC=uclibc
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
LIBC=uclibc
else
-LIBC=
+LIBC=gnu
endif
+# The ABI suffix is a bit special on ARM, as it needs to be
+# -uclibcgnueabi for uClibc EABI, -uclibc for uClibc OABI, -gnueabi
+# for glibc EABI and -gnu for glibc OABI. This means that the LIBC and
+# ABI aren't strictly orthogonal, which explains why we need the test
+# on LIBC below.
ifeq ($(BR2_ARM_EABI),y)
+ifeq ($(LIBC),uclibc)
ABI=gnueabi
+else
+ABI=eabi
+endif
endif
REAL_GNU_TARGET_NAME=$(ARCH)-unknown-linux-$(LIBC)$(ABI)