summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index aca3e4b07..f8557f700 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -1,5 +1,8 @@
-MAKE1=make
-MAKE=make -j$(BR2_JLEVEL)
+ifndef MAKE
+MAKE=make
+endif
+MAKE1:=$(MAKE) MAKE="$(firstword $(MAKE)) -j1"
+MAKE:=$(MAKE) -j$(BR2_JLEVEL)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))