summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 31f5ab646..1ace683c2 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -442,12 +442,13 @@ $(BUILD_DIR)/%/.stamp_cleaned:
rm -f $(@D)/.stamp_built
# Uninstall package from target and staging
+# Uninstall commands tend to fail, so remove the stamp files first
$(BUILD_DIR)/%/.stamp_uninstalled:
@$(call MESSAGE,"Uninstalling")
- $($(PKG)_UNINSTALL_STAGING_CMDS)
rm -f $($(PKG)_TARGET_INSTALL_STAGING)
- $($(PKG)_UNINSTALL_TARGET_CMDS)
rm -f $($(PKG)_TARGET_INSTALL_TARGET)
+ $($(PKG)_UNINSTALL_STAGING_CMDS)
+ $($(PKG)_UNINSTALL_TARGET_CMDS)
# Remove package sources
$(BUILD_DIR)/%/.stamp_dircleaned: