summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index e85eb1549..a27804b81 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -542,7 +542,12 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-$(2)_DEPENDENCIES ?=
+ifndef $(2)_DEPENDENCIES
+ ifdef $(3)_DEPENDENCIES
+ $(2)_DEPENDENCIES = $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+ endif
+endif
+
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO
$(2)_INSTALL_TARGET ?= YES