summaryrefslogtreecommitdiff
path: root/package/acl/acl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/acl/acl.mk')
-rw-r--r--package/acl/acl.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/acl/acl.mk b/package/acl/acl.mk
new file mode 100644
index 000000000..11768f617
--- /dev/null
+++ b/package/acl/acl.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# acl
+#
+#############################################################
+
+ACL_VERSION = 2.2.51
+ACL_SOURCE = acl-$(ACL_VERSION).src.tar.gz
+ACL_SITE = http://download.savannah.gnu.org/releases/acl
+ACL_INSTALL_STAGING = YES
+ACL_DEPENDENCIES = attr
+ACL_CONF_OPT = --enable-gettext=no
+
+# While the configuration system uses autoconf, the Makefiles are
+# hand-written and do not use automake. Therefore, we have to hack
+# around their deficiencies by passing installation paths.
+ACL_INSTALL_STAGING_OPT = \
+ prefix=$(STAGING_DIR)/usr \
+ exec_prefix=$(STAGING_DIR)/usr \
+ PKG_DEVLIB_DIR=$(STAGING_DIR)/usr/lib \
+ install-dev install-lib
+
+ACL_INSTALL_TARGET_OPT = \
+ prefix=$(TARGET_DIR)/usr \
+ exec_prefix=$(TARGET_DIR)/usr \
+ install install-lib
+
+$(eval $(call AUTOTARGETS,package,acl))