summaryrefslogtreecommitdiff
path: root/package/beecrypt/beecrypt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/beecrypt/beecrypt.mk')
-rw-r--r--package/beecrypt/beecrypt.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
new file mode 100644
index 000000000..d26d31d8f
--- /dev/null
+++ b/package/beecrypt/beecrypt.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# beecrypt
+#
+#############################################################
+BEECRYPT_VERSION = 4.1.2
+BEECRYPT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/beecrypt
+BEECRYPT_AUTORECONF = YES
+BEECRYPT_INSTALL_STAGING = YES
+
+BEECRYPT_CONF_OPT = --without-cplusplus \
+ --without-java \
+ --without-python \
+ --disable-rpath
+
+BEECRYPT_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
+
+$(eval $(call AUTOTARGETS,package,beecrypt))