summaryrefslogtreecommitdiff
path: root/package/config/kconfig-to-buildroot2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/config/kconfig-to-buildroot2.patch')
-rw-r--r--package/config/kconfig-to-buildroot2.patch20
1 files changed, 18 insertions, 2 deletions
diff --git a/package/config/kconfig-to-buildroot2.patch b/package/config/kconfig-to-buildroot2.patch
index 5f5d8ee7f..3348b85a1 100644
--- a/package/config/kconfig-to-buildroot2.patch
+++ b/package/config/kconfig-to-buildroot2.patch
@@ -7,11 +7,11 @@
gconf.c | 4 -
gconf.glade | 2
mconf.c | 39 +++++++++----------
- qconf.cc | 3 -
+ qconf.cc | 5 +-
util.c | 105 +++++++++++++++++++++++++++++++++++++++++++++++++++-
zconf.tab.c_shipped | 2
zconf.y | 2
- 12 files changed, 239 insertions(+), 103 deletions(-)
+ 12 files changed, 241 insertions(+), 103 deletions(-)
Index: config/Makefile
===================================================================
@@ -741,6 +741,22 @@ Index: config/qconf.cc
setCaption(title);
width = configSettings->readNumEntry("/window width", d->width() - 64);
+@@ -1612,6 +1611,7 @@
+ {
+ if (!conf_get_changed()) {
+ e->accept();
++ conf_write_autoconf();
+ return;
+ }
+ QMessageBox mb("qconf", _("Save configuration?"), QMessageBox::Warning,
+@@ -1622,6 +1622,7 @@
+ switch (mb.exec()) {
+ case QMessageBox::Yes:
+ conf_write(NULL);
++ conf_write_autoconf();
+ case QMessageBox::No:
+ e->accept();
+ break;
Index: config/util.c
===================================================================
--- config.orig/util.c