summaryrefslogtreecommitdiff
path: root/package/cups/cups.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/cups/cups.mk')
-rw-r--r--package/cups/cups.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index d1bf0fa20..9051e0d0f 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -74,6 +74,7 @@ $(CUPS_DIR)/.unpacked: $(DL_DIR)/$(CUPS_SOURCE)
touch $@
$(CUPS_DIR)/.configured: $(CUPS_DIR)/.unpacked
+ cd $(CUPS_DIR) && $(AUTOCONF)
(cd $(CUPS_DIR) && \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
@@ -109,7 +110,7 @@ $(CUPS_DIR)/.installed: $(CUPS_DIR)/.compiled
$(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" $(STAGING_DIR)/usr/bin/cups-config
touch $@
-cups: uclibc $(CUPS_DEPENDENCIES) $(CUPS_DIR)/.installed
+cups: uclibc host-autoconf $(CUPS_DEPENDENCIES) $(CUPS_DIR)/.installed
cups-source: $(DL_DIR)/$(CUPS_SOURCE)