summaryrefslogtreecommitdiff
path: root/package/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk9
1 files changed, 3 insertions, 6 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index d68f43414..cfa4e7feb 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -18,12 +18,9 @@ DBUS_XML:=expat
DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
else
DBUS_XML:=libxml
-# depend on the exact target instead of libxml2 so dbus isn't always
-# considered out-of-date.
-# It would be neat to use $(LIBXML2_TARGET_INSTALL_STAGING) here,
-# but the libxml2 makefile is only parsed after dbus, so that doesn't work
-DBUS_XML_DEP:=$(BUILD_DIR)/libxml2-2.6.29/.stamp_staging_installed
-$(LIBXML2_TARGET_INSTALL_STAGING)
+# Makefile.autotools.in unfortunately has broken dependency handling,
+# so we cannot do the same for libxml2
+DBUS_XML_DEP:=libxml2-install-staging
endif
$(DL_DIR)/$(DBUS_SOURCE):