summaryrefslogtreecommitdiff
path: root/package/efl
diff options
context:
space:
mode:
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/Config.in1
-rw-r--r--package/efl/libedbus/Config.in11
-rw-r--r--package/efl/libedbus/libedbus.mk14
3 files changed, 26 insertions, 0 deletions
diff --git a/package/efl/Config.in b/package/efl/Config.in
index ec8c5137c..c783d7f07 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -18,6 +18,7 @@ source "package/efl/libembryo/Config.in"
source "package/efl/libedje/Config.in"
source "package/efl/libethumb/Config.in"
source "package/efl/libelementary/Config.in"
+source "package/efl/libedbus/Config.in"
endif # BR2_PACKAGE_EFL
diff --git a/package/efl/libedbus/Config.in b/package/efl/libedbus/Config.in
new file mode 100644
index 000000000..3844b52c1
--- /dev/null
+++ b/package/efl/libedbus/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBEDBUS
+ bool "libedbus"
+ select BR2_PACKAGE_LIBEINA
+ select BR2_PACKAGE_LIBECORE
+ depends on BR2_PACKAGE_DBUS
+ help
+ E_Dbus is a set of wrappers around D-Bus APIs so they can be
+ easily used by EFL applications, automatically providing
+ Ecore/main loop integration, as well as Eina data types.
+
+ http://trac.enlightenment.org/e/wiki/E_Dbus
diff --git a/package/efl/libedbus/libedbus.mk b/package/efl/libedbus/libedbus.mk
new file mode 100644
index 000000000..34f34a7c0
--- /dev/null
+++ b/package/efl/libedbus/libedbus.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libedbus
+#
+#############################################################
+
+LIBEDBUS_VERSION = 1.1.0
+LIBEDBUS_SOURCE = e_dbus-$(LIBEDBUS_VERSION).tar.bz2
+LIBEDBUS_SITE = http://download.enlightenment.org/releases/
+LIBEDBUS_INSTALL_STAGING = YES
+
+LIBEDBUS_DEPENDENCIES = host-pkg-config dbus libeina libecore
+
+$(eval $(call AUTOTARGETS))