summaryrefslogtreecommitdiff
path: root/package/games/prboom/prboom.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/games/prboom/prboom.mk')
-rw-r--r--package/games/prboom/prboom.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index 228c78886..3a50fd502 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -3,20 +3,26 @@
# PrBoom
#
#############################################################
-PRBOOM_VERSION = 2.4.7
+PRBOOM_VERSION = 2.5.0
+PRBOOM_CONF_ENV = ac_cv_type_uid_t=yes
PRBOOM_DEPENDENCIES = sdl SDL_net sdl_mixer
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+PRBOOM_DEPENDENCIES += libpng
+endif
+
PRBOOM_CONF_OPT = \
--oldincludedir=$(STAGING_DIR)/usr/include \
--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-cpu-opt \
--disable-sdltest \
- --disable-gl \
- --without-x
+ --disable-gl
+# endianness detection isn't used when cross compiling
define PRBOOM_BIG_ENDIAN_FIXUP
- $(SED) 's,.*#undef WORDS_BIGENDIAN.*,#define WORDS_BIGENDIAN 1,g' $(PRBOOM_DIR)/config.h
+ $(SED) 's,.*#undef WORDS_BIGENDIAN.*,#define WORDS_BIGENDIAN 1,g' \
+ $(PRBOOM_DIR)/config.h
endef
ifeq ($(BR2_ENDIAN),"BIG")