summaryrefslogtreecommitdiff
path: root/package/gmpc
diff options
context:
space:
mode:
Diffstat (limited to 'package/gmpc')
-rw-r--r--package/gmpc/Config.in8
-rw-r--r--package/gmpc/gmpc.mk3
2 files changed, 8 insertions, 3 deletions
diff --git a/package/gmpc/Config.in b/package/gmpc/Config.in
index a8343617e..7bfe611ea 100644
--- a/package/gmpc/Config.in
+++ b/package/gmpc/Config.in
@@ -1,9 +1,10 @@
config BR2_PACKAGE_GMPC
bool "gmpc"
depends on BR2_PACKAGE_LIBGTK2
+ depends on BR2_USE_WCHAR # glib2
select BR2_PACKAGE_LIBGLIB2
- select BR2_PACKAGE_GETTEXT
- select BR2_PACKAGE_LIBINTL
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
+ select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT_IF_LOCALE
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
select BR2_PACKAGE_LIBMPD
select BR2_PACKAGE_LIBCURL
@@ -14,3 +15,6 @@ config BR2_PACKAGE_GMPC
Music Player Daemon.
http://gmpcwiki.sarine.nl/index.php?title=GMPC
+
+comment "gmpc requires a toolchain with WCHAR support"
+ depends on BR2_PACKAGE_LIBGTK2 && !BR2_USE_WCHAR
diff --git a/package/gmpc/gmpc.mk b/package/gmpc/gmpc.mk
index 0db89b902..6016e7cfc 100644
--- a/package/gmpc/gmpc.mk
+++ b/package/gmpc/gmpc.mk
@@ -11,7 +11,8 @@ GMPC_CONF_ENV = ac_cv_lib_curl_curl_global_init=yes \
ac_cv_path_GOB2=$(GOB2_HOST_BINARY)
GMPC_CONF_OPT = --disable-mmkeys
-GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool
+GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool \
+ $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
ifeq ($(BR2_PACKAGE_XLIB_LIBSM),y)
GMPC_DEPENENCIES += xlib_libSM