summaryrefslogtreecommitdiff
path: root/package/liboil/liboil.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/liboil/liboil.mk')
-rw-r--r--package/liboil/liboil.mk41
1 files changed, 0 insertions, 41 deletions
diff --git a/package/liboil/liboil.mk b/package/liboil/liboil.mk
deleted file mode 100644
index 16f6d1358..000000000
--- a/package/liboil/liboil.mk
+++ /dev/null
@@ -1,41 +0,0 @@
-#############################################################
-#
-# liboil
-#
-#############################################################
-LIBOIL_VERSION = 0.3.15
-LIBOIL_SOURCE = liboil-$(LIBOIL_VERSION).tar.gz
-LIBOIL_SITE = http://liboil.freedesktop.org/download
-LIBOIL_AUTORECONF = YES
-LIBOIL_INSTALL_STAGING = YES
-LIBOIL_INSTALL_TARGET = YES
-
-# Checking if unaligned memory access works correctly cannot be done when cross
-# compiling. For the following architectures there is no information available
-# in the configure script.
-ifeq ($(BR2_avr32),y)
-LIBOIL_CONF_ENV = as_cv_unaligned_access=no
-endif
-ifeq ($(BR2_x86_64),y)
-LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
-endif
-
-LIBOIL_CONF_OPT+=--with-gnu-ld
-
-ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
-LIBOIL_GLIB_DEP = libglib2
-endif
-
-ifeq ($(BR2_VFP_FLOAT),y)
-LIBOIL_CONF_OPT+=--enable-vfp
-endif
-
-LIBOIL_DEPENDENCIES = $(LIBOIL_GLIB_DEP)
-
-define LIBOIL_TARGET_CLEANUP
- rm -f $(TARGET_DIR)/usr/bin/oil-bugreport
-endef
-
-LIBOIL_POST_INSTALL_TARGET_HOOKS += LIBOIL_TARGET_CLEANUP
-
-$(eval $(call AUTOTARGETS))