summaryrefslogtreecommitdiff
path: root/package/libplayer/libplayer-add-fpic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libplayer/libplayer-add-fpic.patch')
-rw-r--r--package/libplayer/libplayer-add-fpic.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/libplayer/libplayer-add-fpic.patch b/package/libplayer/libplayer-add-fpic.patch
new file mode 100644
index 000000000..e4b227f91
--- /dev/null
+++ b/package/libplayer/libplayer-add-fpic.patch
@@ -0,0 +1,18 @@
+Add -fPIC to CFLAGS
+
+-fPIC is needed to build shared library code.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -9,6 +9,7 @@
+ SHARED_LIBNAME_VERSION = $(SHARED_LIBNAME).$(VERSION)
+ SHARED_LIBNAME_MAJOR = $(SHARED_LIBNAME).$(shell echo $(VERSION) | cut -f1 -d.)
+ SHARED_LIBNAME_FLAGS = -shared -Wl,-soname,$(SHARED_LIBNAME_MAJOR)
++CFLAGS = -fPIC
+
+ ifeq ($(BUILD_STATIC),yes)
+ BUILD_RULES += lib_static