summaryrefslogtreecommitdiff
path: root/package/libxml2
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/Config.in10
-rw-r--r--package/libxml2/libxml2.mk4
2 files changed, 12 insertions, 2 deletions
diff --git a/package/libxml2/Config.in b/package/libxml2/Config.in
index cb5c49594..6d8ee45cf 100644
--- a/package/libxml2/Config.in
+++ b/package/libxml2/Config.in
@@ -6,3 +6,13 @@ config BR2_PACKAGE_LIBXML2
Requires WCHAR
ftp://xmlsoft.org/libxml2
+
+config BR2_PACKAGE_LIBXML2_TARGET_HEADERS
+ bool "libxml2 target headers"
+ default n
+ help
+ XML C Parser
+ Requires WCHAR
+
+ ftp://xmlsoft.org/libxml2
+
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 0e6fc2d4c..d9e2a35e6 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -53,11 +53,11 @@ libxml2: uclibc $(TARGET_DIR)/usr/lib/libxml2.so libxml2-headers
$(STAGING_DIR)/usr/include/libxml: $(TARGET_DIR)/usr/lib/libxml2.a
cp -af $(LIBXML2_DIR)/include/libxml $(STAGING_DIR)/usr/include/libxml2
-$(TARGET_DIR)/usr/include: libxml2-headers
+$(TARGET_DIR)/usr/include/libxml2: libxml2-headers
cp -af $(LIBXML2_DIR)/include/libxml $(TARGET_DIR)/usr/include/libxml2
-libxml2-headers: $(STAGING_DIR)/usr/include/libxml2
+libxml2-headers: $(STAGING_DIR)/usr/include/libxml
libxml2-target-headers: $(TARGET_DIR)/usr/include/libxml2