summaryrefslogtreecommitdiff
path: root/package/libxml2
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml2')
-rw-r--r--package/libxml2/libxml2.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index d07f631a8..2a267b2f9 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -30,6 +30,14 @@ HOST_LIBXML2_CONF_OPT = \
--enable-shared --without-debugging --without-python \
--without-threads
+define LIBXML2_REMOVE_CONFIG_SCRIPTS
+ $(RM) -f $(TARGET_DIR)/usr/bin/xml2-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+LIBXML2_POST_INSTALL_TARGET_HOOKS += LIBXML2_REMOVE_CONFIG_SCRIPTS
+endif
+
$(eval $(call AUTOTARGETS,package,libxml2))
$(eval $(call AUTOTARGETS,package,libxml2,host))