summaryrefslogtreecommitdiff
path: root/package/lighttpd/lighttpd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/lighttpd/lighttpd.mk')
-rw-r--r--package/lighttpd/lighttpd.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index a41d9c98e..131e87e72 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -30,6 +30,20 @@ else
LIGHTTPD_CONF_OPT += --without-openssl
endif
+ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_ZLIB)),y)
+LIGHTTPD_DEPENDENCIES += zlib
+LIGHTTPD_CONF_OPT += --with-zlib
+else
+LIGHTTPD_CONF_OPT += --without-zlib
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_BZIP2)),y)
+LIGHTTPD_DEPENDENCIES += bzip2
+LIGHTTPD_CONF_OPT += --with-bzip2
+else
+LIGHTTPD_CONF_OPT += --without-bzip2
+endif
+
ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_PCRE)),y)
LIGHTTPD_CONF_ENV += PCRE_LIB="-lpcre"
LIGHTTPD_DEPENDENCIES += pcre