summaryrefslogtreecommitdiff
path: root/package/ncurses/ncurses.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ncurses/ncurses.mk')
-rw-r--r--package/ncurses/ncurses.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index ae3f3fb70..0d425280b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -26,6 +26,7 @@
NCURSES_VERSION = 5.7
NCURSES_SITE = $(BR2_GNU_MIRROR)/ncurses
NCURSES_INSTALL_STAGING = YES
+NCURSES_DEPENDENCIES = host-ncurses
NCURSES_CONF_OPT = \
--with-shared \
@@ -120,4 +121,18 @@ define NCURSES_INSTALL_TARGET_CMDS
$(NCURSES_INSTALL_TARGET_DEVFILES)
endef # NCURSES_INSTALL_TARGET_CMDS
+#
+# On systems with an older version of tic, the installation of ncurses hangs
+# forever. To resolve the problem, build a static version of tic on host
+# ourselves, and use that during installation.
+#
+define HOST_NCURSES_BUILD_CMDS
+ $(MAKE1) -C $(@D) sources
+ $(MAKE) -C $(@D)/progs tic
+endef
+
+HOST_NCURSES_CONF_OPT = \
+ --without-shared
+
$(eval $(call AUTOTARGETS,package,ncurses))
+$(eval $(call AUTOTARGETS,package,ncurses,host))