summaryrefslogtreecommitdiff
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
new file mode 100644
index 000000000..36bfb3bb6
--- /dev/null
+++ b/package/neon/neon.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# neon
+#
+#############################################################
+NEON_VERSION = 0.28.2
+NEON_SITE = http://www.webdav.org/neon/
+NEON_INSTALL_STAGING = YES
+
+NEON_CONF_OPT+=--enable-shared --without-gssapi --disable-rpath
+
+NEON_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
+
+ifeq ($(strip $(BR2_PACKAGE_NEON_LIBXML2)),y)
+NEON_CONF_OPT+=--with-libxml2=yes
+NEON_CONF_OPT+=--with-expat=no
+NEON_DEPENDENCIES+=libxml2
+endif
+ifeq ($(strip $(BR2_PACKAGE_NEON_EXPAT)),y)
+NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_CONF_OPT+=--with-libxml2=no
+NEON_DEPENDENCIES+=expat
+endif
+
+$(eval $(call AUTOTARGETS,package,neon))