summaryrefslogtreecommitdiff
path: root/package/neon/neon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/neon/neon.mk')
-rw-r--r--package/neon/neon.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index e92e134b6..61cf7527e 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -16,6 +16,12 @@ NEON_CONF_OPT+=--with-libxml2=yes
NEON_CONF_OPT+=--with-expat=no
NEON_DEPENDENCIES+=libxml2
endif
+ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
+NEON_CONF_OPT+=--with-zlib=$(STAGING_DIR)
+NEON_DEPENDENCIES+=zlib
+else
+NEON_CONF_OPT+=--without-zlib
+endif
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no