summaryrefslogtreecommitdiff
path: root/package/openssl/openssl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssl/openssl.mk')
-rw-r--r--package/openssl/openssl.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index a238ce859..a0e6f7e54 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -73,3 +73,11 @@ else
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/engines/lib*.so
endif
touch $@
+
+$(OPENSSL_TARGET_UNINSTALL):
+ $(call MESSAGE,"Uninstalling")
+ rm -rf $(addprefix $(TARGET_DIR)/,etc/ssl usr/bin/openssl usr/include/openssl)
+ rm -rf $(addprefix $(TARGET_DIR)/usr/lib/,ssl engines libcrypto* libssl* pkgconfig/libcrypto.pc)
+ rm -rf $(addprefix $(STAGING_DIR)/,etc/ssl usr/bin/openssl usr/include/openssl)
+ rm -rf $(addprefix $(STAGING_DIR)/usr/lib/,ssl engines libcrypto* libssl* pkgconfig/libcrypto.pc)
+ rm -f $(OPENSSL_TARGET_INSTALL_TARGET) $(OPENSSL_HOOK_POST_INSTALL)