summaryrefslogtreecommitdiff
path: root/package/openvpn
diff options
context:
space:
mode:
Diffstat (limited to 'package/openvpn')
-rw-r--r--package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch30
-rw-r--r--package/openvpn/openvpn.mk18
2 files changed, 38 insertions, 10 deletions
diff --git a/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch b/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch
new file mode 100644
index 000000000..546655875
--- /dev/null
+++ b/package/openvpn/openvpn-2.1.3-fix-build-with-disable-crypto.patch
@@ -0,0 +1,30 @@
+[PATCH] fix build with --disable-crypto
+
+options.c is missing the definition for struct context when built with
+--disable-crypto, as it then doesn't get pulled in through push.h,
+leading to build errors like:
+
+options.c: In function ‘parse_http_proxy_fallback’:
+options.c:1474: error: dereferencing pointer to incomplete type
+options.c:1477: error: dereferencing pointer to incomplete type
+options.c:1478: error: dereferencing pointer to incomplete type
+
+Fix it by including forward.h
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ options.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: openvpn-2.1.3/options.c
+===================================================================
+--- openvpn-2.1.3.orig/options.c
++++ openvpn-2.1.3/options.c
+@@ -29,6 +29,7 @@
+
+ #include "syshead.h"
+
++#include "forward.h"
+ #include "buffer.h"
+ #include "error.h"
+ #include "common.h"
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 084ee2f79..7d8fb0c6f 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -4,7 +4,7 @@
#
#############################################################
-OPENVPN_VERSION = 2.1.1
+OPENVPN_VERSION = 2.1.3
OPENVPN_SITE = http://openvpn.net/release
OPENVPN_CONF_OPT = --enable-small
@@ -26,20 +26,18 @@ else
OPENVPN_CONF_OPT += --disable-crypto --disable-ssl
endif
-$(eval $(call AUTOTARGETS,package,openvpn))
-
-$(OPENVPN_TARGET_INSTALL_TARGET):
- $(call MESSAGE,"Installing")
- $(INSTALL) -m 755 $(OPENVPN_DIR)/openvpn \
+define OPENVPN_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 $(@D)/openvpn \
$(TARGET_DIR)/usr/sbin/openvpn
if [ ! -f $(TARGET_DIR)/etc/init.d/openvpn ]; then \
$(INSTALL) -m 755 -D package/openvpn/openvpn.init \
$(TARGET_DIR)/etc/init.d/openvpn; \
fi
- touch $@
+endef
-$(OPENVPN_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define OPENVPN_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/openvpn
rm -f $(TARGET_DIR)/etc/init.d/openvpn
- rm -f $(OPENVPN_TARGET_INSTALL_TARGET) $(OPENVPN_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,openvpn))