summaryrefslogtreecommitdiff
path: root/package/opkg/opkg.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/opkg/opkg.mk')
-rw-r--r--package/opkg/opkg.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/opkg/opkg.mk b/package/opkg/opkg.mk
new file mode 100644
index 000000000..9cfaa26c1
--- /dev/null
+++ b/package/opkg/opkg.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# opkg
+#
+#############################################################
+
+OPKG_VERSION = 0.1.8
+OPKG_SOURCE = opkg-$(OPKG_VERSION).tar.gz
+OPKG_SITE = http://opkg.googlecode.com/files
+OPKG_INSTALL_STAGING = YES
+OPKG_CONF_OPT = --disable-curl --disable-gpg
+
+# Ensure directory for lockfile exists
+define OPKG_CREATE_LOCKDIR
+ mkdir -p $(TARGET_DIR)/usr/lib/opkg
+endef
+
+OPKG_POST_INSTALL_TARGET_HOOKS += OPKG_CREATE_LOCKDIR
+
+$(eval $(call AUTOTARGETS))