summaryrefslogtreecommitdiff
path: root/package/pcre/pcre.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pcre/pcre.mk')
-rw-r--r--package/pcre/pcre.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
new file mode 100644
index 000000000..f6f7003d0
--- /dev/null
+++ b/package/pcre/pcre.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# PCRE
+#
+#############################################################
+PCRE_VERSION = 7.6
+PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
+PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
+PCRE_INSTALL_STAGING = YES
+PCRE_INSTALL_TARGET = YES
+
+PCRE_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) --prefix=/usr \
+ --includedir=/usr/include
+
+PCRE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,pcre))