summaryrefslogtreecommitdiff
path: root/package/php/php.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/php/php.mk')
-rw-r--r--package/php/php.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index cf4422f6f..f9550d932 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -19,10 +19,13 @@ else
endif
ifneq ($(BR2_PACKAGE_PHP_CGI),y)
- PHP_CGI="--disable-cgi"
+ PHP_CGI=--disable-cgi
else
- PHP_CGI="--enable-cgi"
+ PHP_CGI=--enable-cgi
PHP_TARGET_DEPS+=$(TARGET_DIR)/usr/bin/php-cgi
+ ifeq ($(BR2_PACKAGE_PHP_FASTCGI),y)
+ PHP_CGI+=--enable-fastcgi
+ endif
endif
ifeq ($(BR2_PACKAGE_PHP_OPENSSL),y)
@@ -69,6 +72,7 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
+ --with-config-file-path=/etc \
--datadir=/usr/share/misc \
--localstatedir=/var \
--mandir=/usr/man \
@@ -77,6 +81,7 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
--enable-spl \
--enable-session \
--enable-sockets \
+ --enable-posix \
--with-pcre-regex \
--without-pear \
--disable-ipv6 \
@@ -100,10 +105,12 @@ $(PHP_DIR)/.staged: $(PHP_DIR)/.built
$(TARGET_DIR)/usr/bin/php: $(PHP_DIR)/.staged
cp -dpf $(STAGING_DIR)/usr/bin/php $(TARGET_DIR)/usr/bin/php
chmod 755 $(TARGET_DIR)/usr/bin/php
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/php
$(TARGET_DIR)/usr/bin/php-cgi: $(PHP_DIR)/.staged
cp -dpf $(STAGING_DIR)/usr/bin/php-cgi $(TARGET_DIR)/usr/bin/php-cgi
chmod 755 $(TARGET_DIR)/usr/bin/php-cgi
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/php-cgi
$(TARGET_DIR)/etc/php.ini: $(PHP_DIR)/.staged
cp $(PHP_DIR)/php.ini-dist $(TARGET_DIR)/etc/php.ini
@@ -112,6 +119,9 @@ php: uclibc $(PHP_DEPS) $(PHP_TARGET_DEPS) $(TARGET_DIR)/etc/php.ini
php-clean:
rm -f $(PHP_DIR)/.configured $(PHP_DIR)/.built $(PHP_DIR)/.staged
+ rm -f $(TARGET_DIR)/usr/bin/php $(TARGET_DIR)/usr/bin/php-cgi
+ rm -f $(STAGING_DIR)/usr/bin/php* $(STAGING_DIR)/usr/man/man1/php*
+ rm -rf $(STAGING_DIR)/usr/include/php
-$(MAKE) -C $(PHP_DIR) clean
php-dirclean: