summaryrefslogtreecommitdiff
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 4f42e59e8..aaf965e3c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
QT_CONFIGURE+= -platform linux-g++
endif