summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.in8
-rw-r--r--package/qt/qt.mk2
2 files changed, 7 insertions, 3 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 4371fc36e..b09d6429c 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -243,7 +243,7 @@ config BR2_PACKAGE_QT_EMB_PLATFORM
default "x86_64" if BR2_x86_64
default "mips" if BR2_mips
default "mips" if BR2_mipsel
- default "ppc" if BR2_powerpc
+ default "powerpc" if BR2_powerpc
# Not that I really believe these will work..
default "generic" if BR2_alpha
default "generic" if BR2_chris
@@ -263,13 +263,17 @@ endif
config BR2_PACKAGE_QT_PHONON
bool "Phonon Module"
- select BR2_PACKAGE_GSTREAMER
+ depends on BR2_PACKAGE_GSTREAMER
select BR2_PACKAGE_GST_PLUGINS_BASE
+ default y
help
Build the Phonon module. Support for different audio/video
formats can be configured at the GStreamer package.
If unsure, say n.
+comment "Phonon module needs gstreamer"
+ depends on !BR2_PACKAGE_GSTREAMER
+
config BR2_PACKAGE_QT_PHONON_BACKEND
bool "Phonon Module Backend"
depends on BR2_PACKAGE_QT_PHONON
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 4f42e59e8..aaf965e3c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
QT_CONFIGURE+= -platform linux-g++
endif