summaryrefslogtreecommitdiff
path: root/package/qtopia4/qtopia4.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/qtopia4/qtopia4.mk')
-rw-r--r--package/qtopia4/qtopia4.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 42825194d..fc95da48a 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -21,7 +21,7 @@
# x86 crosscompiling under linux x86. Please remove it when the workaround
# is no longer necessary.
-QTOPIA4_VERSION:=4.5.1
+QTOPIA4_VERSION:=4.5.2
QTOPIA4_CAT:=$(BZCAT)
BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME)))
@@ -440,6 +440,8 @@ endif
$(call QTOPIA4_QMAKE_SET,OBJCOPY,$(TARGET_OBJCOPY))
$(call QTOPIA4_QMAKE_SET,RANLIB,$(TARGET_RANLIB))
$(call QTOPIA4_QMAKE_SET,STRIP,$(TARGET_STRIP))
+ $(call QTOPIA4_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
+ $(call QTOPIA4_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
-[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
$(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.