summaryrefslogtreecommitdiff
path: root/package/socat
diff options
context:
space:
mode:
Diffstat (limited to 'package/socat')
-rw-r--r--package/socat/socat-no-documentation.patch37
-rw-r--r--package/socat/socat.mk15
2 files changed, 51 insertions, 1 deletions
diff --git a/package/socat/socat-no-documentation.patch b/package/socat/socat-no-documentation.patch
new file mode 100644
index 000000000..ce088dfaf
--- /dev/null
+++ b/package/socat/socat-no-documentation.patch
@@ -0,0 +1,37 @@
+socat: disable documentation build/installation
+
+The documentation generation process requires a special yold2man
+program, for which we don't have a package in Buildroot. Since we
+generally don't care much about documentation of packages, just adjust
+the package Makefile.in to not build/install its documentation.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -93,7 +93,7 @@
+ Config/Makefile.Cygwin-1-5-25 Config/config.Cygwin-1-5-25.h \
+ Config/Makefile.MacOSX-10-5 Config/config.MacOSX-10-5.h
+
+-all: progs doc
++all: progs
+
+ scmclean: gitclean
+
+@@ -136,13 +136,11 @@
+ strip: progs
+ strip $(PROGS)
+
+-install: progs $(srcdir)/doc/socat.1
++install: progs
+ mkdir -p $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 procan $(DESTDIR)$(BINDEST)
+ $(INSTALL) -m 755 filan $(DESTDIR)$(BINDEST)
+- mkdir -p $(DESTDIR)$(MANDEST)/man1
+- $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/
+
+ uninstall:
+ rm -f $(DESTDIR)$(BINDEST)/socat
diff --git a/package/socat/socat.mk b/package/socat/socat.mk
index 5f7feacc2..bd435cf08 100644
--- a/package/socat/socat.mk
+++ b/package/socat/socat.mk
@@ -4,7 +4,7 @@
#
#############################################################
-SOCAT_VERSION = 2.0.0-b4
+SOCAT_VERSION = 2.0.0-b5
SOCAT_SOURCE = socat-$(SOCAT_VERSION).tar.bz2
SOCAT_SITE = http://www.dest-unreach.org/socat/download/
SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
@@ -12,4 +12,17 @@ SOCAT_CONF_ENV = sc_cv_termios_ispeed=no \
sc_cv_sys_tabdly_shift=11 \
sc_cv_sys_csize_shift=4
+# We need to run autoconf to regenerate the configure script, in order
+# to ensure that the test checking linux/ext2_fs.h works
+# properly. However, the package only uses autoconf and not automake,
+# so we can't use the normal autoreconf logic.
+
+SOCAT_DEPENDENCIES = host-autoconf
+
+define SOCAT_RUN_AUTOCONF
+ (cd $(@D); $(HOST_DIR)/usr/bin/autoconf)
+endef
+
+SOCAT_PRE_CONFIGURE_HOOKS += SOCAT_RUN_AUTOCONF
+
$(eval $(call AUTOTARGETS))