summaryrefslogtreecommitdiff
path: root/package/udev/udev.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/udev/udev.mk')
-rw-r--r--package/udev/udev.mk23
1 files changed, 15 insertions, 8 deletions
diff --git a/package/udev/udev.mk b/package/udev/udev.mk
index 1825396c3..d445a2f08 100644
--- a/package/udev/udev.mk
+++ b/package/udev/udev.mk
@@ -3,28 +3,35 @@
# udev
#
#############################################################
-UDEV_VERSION = 173
+UDEV_VERSION = 181
UDEV_SOURCE = udev-$(UDEV_VERSION).tar.bz2
UDEV_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/hotplug/
UDEV_INSTALL_STAGING = YES
+# mq_getattr is in librt
+UDEV_CONF_ENV += LIBS=-lrt
+
UDEV_CONF_OPT = \
--sbindir=/sbin \
--with-rootlibdir=/lib \
- --libexecdir=/lib/udev \
+ --libexecdir=/lib \
+ --with-usb-ids-path=/usr/share/hwdata/usb.ids \
+ --with-pci-ids-path=/usr/share/hwdata/pci.ids \
+ --with-firmware-path=/lib/firmware \
--disable-introspection
-UDEV_DEPENDENCIES = host-gperf host-pkg-config
+UDEV_DEPENDENCIES = host-gperf host-pkg-config util-linux kmod
+
+ifeq ($(BR2_PACKAGE_UDEV_RULES_GEN),y)
+UDEV_CONF_OPT += --enable-rule_generator
+endif
ifeq ($(BR2_PACKAGE_UDEV_ALL_EXTRAS),y)
-UDEV_DEPENDENCIES += libusb libusb-compat acl usbutils hwdata libglib2
-UDEV_CONF_OPT += \
- --with-pci-ids-path=$(TARGET_DIR)/usr/share/hwdata/pci.ids \
- --with-usb-ids-path=$(TARGET_DIR)/usr/share/hwdata/usb.ids \
+UDEV_DEPENDENCIES += acl hwdata libglib2
+UDEV_CONF_OPT += \
--enable-udev_acl
else
UDEV_CONF_OPT += \
- --disable-hwdb \
--disable-gudev
endif