summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/config/.gitignore4
-rw-r--r--package/coreutils/Config.in4
-rw-r--r--package/coreutils/coreutils-7.4-rename-m4-fix.patch25
-rw-r--r--package/coreutils/coreutils.mk7
-rw-r--r--package/tar/Config.in4
5 files changed, 37 insertions, 7 deletions
diff --git a/package/config/.gitignore b/package/config/.gitignore
index 9067e6885..161a19ada 100644
--- a/package/config/.gitignore
+++ b/package/config/.gitignore
@@ -1,6 +1,10 @@
/buildroot-config
/conf
/mconf
+/qconf
+/qconf.moc
+/.tmp_qtcheck
+/lkc_defs.h
/lex.zconf.c
/zconf.hash.c
/zconf.tab.c
diff --git a/package/coreutils/Config.in b/package/coreutils/Config.in
index 5dfe43c9d..a7159cf9e 100644
--- a/package/coreutils/Config.in
+++ b/package/coreutils/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_COREUTILS
bool "coreutils"
- depends on BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION
+ depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
help
All of the basic file/text/shell utilities. These are the
core utilities which are expected to exist on every system.
@@ -14,4 +14,4 @@ config BR2_PACKAGE_COREUTILS
http://www.gnu.org/software/coreutils/
comment "coreutils requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
- depends on !(BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION)
+ depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
diff --git a/package/coreutils/coreutils-7.4-rename-m4-fix.patch b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
new file mode 100644
index 000000000..f869f439c
--- /dev/null
+++ b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
@@ -0,0 +1,25 @@
+Commit 7fcb389fb4cd5ba26e330fef991ffdc05392f289 from gnulib, to fix
+the rename bugs detection macros.
+---
+ m4/rename.m4 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: coreutils-7.4/m4/rename.m4
+===================================================================
+--- coreutils-7.4.orig/m4/rename.m4
++++ coreutils-7.4/m4/rename.m4
+@@ -51,12 +51,12 @@
+ AC_LIBOBJ([rename])
+ AC_DEFINE([rename], [rpl_rename],
+ [Define to rpl_rename if the replacement function should be used.])
+- if test $gl_cv_func_rename_trailing_slash_bug; then
++ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
+ AC_DEFINE([RENAME_TRAILING_SLASH_BUG], [1],
+ [Define if rename does not work for source file names with a trailing
+ slash, like the one from SunOS 4.1.1_U1.])
+ fi
+- if test $gl_cv_func_rename_dest_exists_bug; then
++ if test $gl_cv_func_rename_dest_exists_bug = yes; then
+ AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
+ [Define if rename does not work when the destination file exists,
+ as on Windows.])
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index 31de2d5b8..2c9c0d3b3 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -3,11 +3,11 @@
# coreutils
#
#############################################################
-COREUTILS_VERSION:=6.9
-COREUTILS_SOURCE:=coreutils-$(COREUTILS_VERSION).tar.bz2
+COREUTILS_VERSION:=7.4
+COREUTILS_SOURCE:=coreutils-$(COREUTILS_VERSION).tar.gz
#COREUTILS_SITE:=ftp://alpha.gnu.org/gnu/coreutils/
COREUTILS_SITE:=$(BR2_GNU_MIRROR)/coreutils
-COREUTILS_CAT:=$(BZCAT)
+COREUTILS_CAT:=$(ZCAT)
COREUTILS_DIR:=$(BUILD_DIR)/coreutils-$(COREUTILS_VERSION)
COREUTILS_BINARY:=src/vdir
COREUTILS_TARGET_BINARY:=bin/vdir
@@ -59,6 +59,7 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
ac_cv_func_mkstemp=yes \
utils_cv_func_mkstemp_limitations=no \
utils_cv_func_mkdir_trailing_slash_bug=no \
+ gl_cv_func_rename_dest_exists_bug=no \
ac_cv_func_memcmp_working=yes \
ac_cv_have_decl_malloc=yes \
gl_cv_func_malloc_0_nonnull=yes \
diff --git a/package/tar/Config.in b/package/tar/Config.in
index a25794939..20529e378 100644
--- a/package/tar/Config.in
+++ b/package/tar/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_TAR
bool "tar"
- depends on BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION
+ depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
help
A program that saves many files together into a single tape or disk
archive, and can restore individual files from the archive.
@@ -8,4 +8,4 @@ config BR2_PACKAGE_TAR
http://www.gnu.org/software/tar/
comment "tar requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
- depends on !(BR2_USE_WCHAR && BR2_UCLIBC_PROGRAM_INVOCATION)
+ depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)