summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in25
-rw-r--r--package/Makefile.in4
-rw-r--r--package/busybox/Config.in71
3 files changed, 15 insertions, 85 deletions
diff --git a/package/Config.in b/package/Config.in
index 6c1c10ecb..f244d930e 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2,16 +2,8 @@ menu "Package Selection for the target"
source "package/busybox/Config.in"
-comment "The minimum needed to build a uClibc development system ---"
+comment "The minimum needed to build a uClibc development system"
-menuconfig BR2_APPLICATIONS
- bool "Common Applications"
- default y
- help
- A set of applications, utilities and libraries for
- text processing, toolchain generation and other things.
-
-if BR2_APPLICATIONS
source "package/bash/Config.in"
source "package/bzip2/Config.in"
if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
@@ -37,6 +29,15 @@ source "package/sed/Config.in"
source "package/tar/Config.in"
endif
+#menuconfig BR2_APPLICATION_SUPPORT
+# bool "Common Applications"
+# default y
+# help
+# A set of applications, utilities and libraries for
+# text processing, toolchain generation and other things.
+
+
+#if BR2_APPLICATION_SUPPORT
comment "Other development stuff"
source "package/autoconf/Config.in"
source "package/automake/Config.in"
@@ -119,7 +120,6 @@ endif
if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
source "package/which/Config.in"
endif
-endif
menuconfig BR2_NETWORK_SUPPORT
bool "Networking"
@@ -128,8 +128,6 @@ menuconfig BR2_NETWORK_SUPPORT
Support for communication, networking and related packages
if BR2_NETWORK_SUPPORT
-comment "Communications applications"
-source "package/microcom/Config.in"
comment "Networking applications"
source "package/argus/Config.in"
source "package/avahi/Config.in"
@@ -157,6 +155,9 @@ source "package/libpcap/Config.in"
source "package/links/Config.in"
source "package/lrzsz/Config.in"
source "package/mdnsresponder/Config.in"
+if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
+source "package/microcom/Config.in"
+endif
source "package/mrouted/Config.in"
source "package/mutt/Config.in"
source "package/nbd/Config.in"
diff --git a/package/Makefile.in b/package/Makefile.in
index 5a47af885..28092992f 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -10,7 +10,7 @@ MAKE1:=$(HOSTMAKE) MAKE="$(firstword $(HOSTMAKE)) -j1"
MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) \
-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
TARGET_LDFLAGS=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
@@ -63,7 +63,7 @@ endif
#########################################################################
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
TOOL_BUILD_DIR=$(BASE_DIR)/$(TOPDIR_PREFIX)toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
# Quotes are needed for spaces et al in path components.
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 431b57e19..f97546bc3 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -1,10 +1,3 @@
-menuconfig BR2_BUSYBOX_MENU
- bool "Busybox configuration -- the default minimal system"
- default y
- help
- Configuration of Busybox,
-
-if BR2_BUSYBOX_MENU
config BR2_PACKAGE_BUSYBOX
bool "BusyBox"
default y
@@ -23,42 +16,10 @@ choice
help
Select the version of BusyBox you wish to use.
- config BR2_BUSYBOX_VERSION_1_0_1
- bool "BusyBox 1.0.1"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_1_3
- bool "BusyBox 1.1.3"
- depends on BR2_DEPRECATED
-
config BR2_BUSYBOX_VERSION_1_2_2_1
bool "BusyBox 1.2.2.1"
depends on BR2_DEPRECATED
- config BR2_BUSYBOX_VERSION_1_4_0
- bool "BusyBox 1.4.0"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_4_1
- bool "BusyBox 1.4.1"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_4_2
- bool "BusyBox 1.4.2"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_5_0
- bool "BusyBox 1.5.0"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_5_1
- bool "BusyBox 1.5.1"
- depends on BR2_DEPRECATED
-
- config BR2_BUSYBOX_VERSION_1_6_0
- bool "BusyBox 1.6.0"
- depends on BR2_DEPRECATED
-
config BR2_BUSYBOX_VERSION_1_6_1
bool "BusyBox 1.6.1"
depends on BR2_DEPRECATED
@@ -77,15 +38,7 @@ endchoice
config BR2_BUSYBOX_VERSION
string
- default "1.0.1" if BR2_BUSYBOX_VERSION_1_0_1
- default "1.1.3" if BR2_BUSYBOX_VERSION_1_1_3
default "1.2.2.1" if BR2_BUSYBOX_VERSION_1_2_2_1
- default "1.4.0" if BR2_BUSYBOX_VERSION_1_4_0
- default "1.4.1" if BR2_BUSYBOX_VERSION_1_4_1
- default "1.4.2" if BR2_BUSYBOX_VERSION_1_4_2
- default "1.5.0" if BR2_BUSYBOX_VERSION_1_5_0
- default "1.5.1" if BR2_BUSYBOX_VERSION_1_5_1
- default "1.6.0" if BR2_BUSYBOX_VERSION_1_6_0
default "1.6.1" if BR2_BUSYBOX_VERSION_1_6_1
default "1.7.0" if BR2_BUSYBOX_VERSION_1_7_0
default "1.7.1" if BR2_BUSYBOX_VERSION_1_7_1
@@ -108,15 +61,7 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
string "BusyBox configuration file to use?"
depends BR2_PACKAGE_BUSYBOX
default "target/device/x86/i386/busybox.config" if BR2_PACKAGE_BUSYBOX_SNAPSHOT
- default "package/busybox/busybox-1.0.1.config" if BR2_BUSYBOX_VERSION_1_0_1
- default "package/busybox/busybox-1.1.3.config" if BR2_BUSYBOX_VERSION_1_1_3
default "package/busybox/busybox-1.2.2.1.config" if BR2_BUSYBOX_VERSION_1_2_2_1
- default "package/busybox/busybox-1.4.0.config" if BR2_BUSYBOX_VERSION_1_4_0
- default "package/busybox/busybox-1.4.1.config" if BR2_BUSYBOX_VERSION_1_4_1
- default "package/busybox/busybox-1.4.1.config" if BR2_BUSYBOX_VERSION_1_4_2
- default "package/busybox/busybox-1.5.0.config" if BR2_BUSYBOX_VERSION_1_5_0
- default "package/busybox/busybox-1.5.0.config" if BR2_BUSYBOX_VERSION_1_5_1
- default "package/busybox/busybox-1.6.0.config" if BR2_BUSYBOX_VERSION_1_6_0
default "package/busybox/busybox-1.6.0.config" if BR2_BUSYBOX_VERSION_1_6_1
default "package/busybox/busybox-1.6.0.config" if BR2_BUSYBOX_VERSION_1_7_0
default "package/busybox/busybox-1.6.0.config" if BR2_BUSYBOX_VERSION_1_7_1
@@ -134,8 +79,6 @@ config BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
Do not show packages in menuconfig that are potentially provided
by busybox.
-comment "Skeleton configuration"
-
config BR2_PACKAGE_BUSYBOX_SKELETON
bool "use minimal target skeleton"
depends on BR2_PACKAGE_BUSYBOX
@@ -144,22 +87,8 @@ config BR2_PACKAGE_BUSYBOX_SKELETON
Use a minimal target skeleton. Make sure to select mdev
which is used to populate /dev/.
-config BR2_HOSTNAME
- string "hostname"
- default "uclibc"
- help
- The hostname string is stored in "/etc/hostname"
-
-config BR2_BANNER
- string "banner"
- default "Welcome to the Erik's uClibc development environment."
- help
- The banner string is stored in "/etc/issue"
-
-
#config BR2_PACKAGE_BUSYBOX_INITRAMFS
# bool "initramfs perusing busybox"
# depends on BR2_PACKAGE_BUSYBOX
# help
# Build small initramfs perusing busybox.
-endif