summaryrefslogtreecommitdiff
path: root/project/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'project/Makefile.in')
-rw-r--r--project/Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index b90f31267..2e8ee1b22 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -4,3 +4,9 @@ TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
#"))
BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
#"))
+
+# All configurable packages (like Busybox,Linux etc) should be built
+# in PROJECT_BUILD_DIR
+PROJECT_BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)project_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)/$(PROJECT)
+BINARIES_DIR:=$(BASE_DIR)/binaries/$(PROJECT)
+TARGET_DIR:=$(PROJECT_BUILD_DIR)/root