summaryrefslogtreecommitdiff
path: root/project
diff options
context:
space:
mode:
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index c4188505b..034b1fa6c 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -25,7 +25,14 @@ TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
#")
+# Buildroot supports building out of tree similarly to the Linux kernel.
+# To use, add O= to the make command line (make O=/tmp/build)
BASE_DIR:=$(shell pwd)
+ifdef O
+ifeq ("$(origin O)", "command line")
+BASE_DIR := $(O)
+endif
+endif
TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
#"))