summaryrefslogtreecommitdiff
path: root/scripts/mkmakefile
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mkmakefile')
-rwxr-xr-xscripts/mkmakefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/scripts/mkmakefile b/scripts/mkmakefile
deleted file mode 100755
index cef2ec707..000000000
--- a/scripts/mkmakefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/sh
-# Generates a small Makefile used in the root of the output
-# directory, to allow make to be started from there.
-# The Makefile also allow for more convenient build of external modules
-
-# Usage
-# $1 - Kernel src directory
-# $2 - Output directory
-
-
-test ! -r $2/Makefile -o -O $2/Makefile || exit 0
-# Only overwrite automatically generated Makefiles
-# (so we do not overwrite buildroot Makefile)
-if test -e $2/Makefile && ! grep -q Automatically $2/Makefile
-then
- exit 0
-fi
-if [ "${quiet}" != "silent_" ]; then
- echo " GEN $2/Makefile"
-fi
-
-cat << EOF > $2/Makefile
-# Automatically generated by $0: don't edit
-
-lastword = \$(word \$(words \$(1)),\$(1))
-makedir := \$(dir \$(call lastword,\$(MAKEFILE_LIST)))
-
-MAKEARGS := -C $1
-MAKEARGS += O=\$(if \$(patsubst /%,,\$(makedir)),\$(CURDIR)/)\$(patsubst %/,%,\$(makedir))
-
-MAKEFLAGS += --no-print-directory
-
-.PHONY: all \$(MAKECMDGOALS)
-
-all := \$(filter-out all Makefile,\$(MAKECMDGOALS))
-
-all:
- \$(MAKE) \$(MAKEARGS) \$(all)
-
-Makefile:;
-
-\$(all): all
- @:
-
-%/: all
- @:
-EOF